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Введение 

Современные устройства аналоговой и цифровой электроники, 

микропроцессорные системы характеризуются большим количеством и 

разнообразием элементов, широким динамическим и частотным диапазоном 

входных и выходных сигналов, вследствие чего их проектирование является 

сложной инженерной задачей. Положение усугубляется при необходимости учета 

значительного числа контролируемых параметров и характеристик компонентов и 

систем. Очевидно, что только новые компьютерные технологии, мощные 

моделирующие среды позволяют существенно повысить эффективность решения 

проектных задач. Необходимо, чтобы инженеры, занимающиеся решением 

подобного рода задач, имели доступ к таким программам, получали практические 

навыки в их применении для улучшения эффективности своей работы. Кроме 

того, эти программные продукты можно использовать как обучающие программы, 

на их основе можно создавать виртуальные лабораторные работы. Это позволит 

более наглядно продемонстрировать студентам исследуемые параметры и 

характеристики конкретных схем. 

На начальном этапе распространения в нашей стране САПР электронной 

аппаратуры на персональных компьютерах наибольшее распространение получил 

пакет программ OrCAD на платформе DOS. Он решал следующие задачи: 

графический ввод принципиальных схем и разработка печатных плат, 

моделирование цифровых устройств и проектирование программируемых 

логических интегральных схем. OrCAD для DOS имел очень удобный редактор 

принципиальных схем, что обусловило его популярность. Моделирование 

аналоговых устройств предполагалось выполнять с помощью программы PSpice 

фирмы MicroSim. В дальнейшем фирма OrCAD интенсивно развивала средства 

моделирования цифровых устройств и интерфейсы с программами разработки 

наиболее популярных программируемых логических интегральных схем. В 

начале 1997г. появилась новая версия OrCAD для Windows. Моделирование 

аналоговой или смешанной аналого-цифровой части проекта проводится с 



 4 

помощью программы PSpice, передавая описание проекта в текстовом виде, или с 

помощью пакета ICAP, интегрируемого с графическим схемным редактором 

OrCAD Capture. В 1998г. под маркой OrCAD начали распространяться программы 

моделирования и оптимизации аналоговых и смешанных аналого-цифровых 

устройств, не имеющих пока интерфейса с редактором схем OrCAD Capture. В 

ноябре 1998г. была выпущена новая система OrCAD 9.0, объединившая все 

перечисленные выше модули под управлением одной интегрированной оболочки. 

В марте 2000г. фирма Cadence Design Systems выпустила очередную версию 

OrCAD 9.2. В нее включили второй редактор принципиальных схем PSpice 

Schematics, заимствованный из популярного в свое время пакета DesignLab. 

1. Основные характеристики системы 

Представление о версии OrCAD 9.2 дает перечень входящих в ее состав 

программных модулей: 

OrCAD Capture – графический редактор схем; 

OrCAD Capture CIS – графический редактор схем, дополненный средством 

ведения аз данных компонентов; 

PSpice Schematics – графический редактор схем, заимствованный из пакета 

DesignLab; 

OrCAD PSpice A/D – программа моделирования аналоговых и смешанных 

аналого-цифровых устройств, данные в которую предаются как из PSpice 

Schematics, так и из OrCAD Capture; 

OrCAD PSpice Optimizer – программа параметрической оптимизации; 

OrCAD Layout – графический редактор печатных плат; 

OrCAD Layout Plus – программа OrCAD Layout, дополненная бессеточным 

автотрассировщиком SmartRoute. 

OrCAD Layout Engineer’s Edition – программа просмотра печатных плат, 

созданных с помощью Layout или Layout Plus, средство общей расстановки 

компонентов на плате и прокладки наиболее критических цепей, выполняемых 
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инженером-схемотехником перед выдачей задания на проектирование печатной 

платы конструктору; 

OrCAD GerbTool – программа создания и доработки управляющих файлов 

для фотоплоттеров; 

Visual CADD – графический редактор фирмы Numera Software (упрощенный 

аналог AutoCAD). 

К пакету OrCAD 9.2 прилагаются библиотеки символов, которые содержат 

более 30 тыс. элементов. Библиотеки символов компонентов представляют собой 

файлы, имеющие расширение имени *.olb, в которых находится вся информация, 

необходимая для создания принципиальных схем и передачи данных в другие 

программы системы OrCAD: 

Abm.olb – функциональные блоки (сумматоры, умножители, интегратор, 

ограничитель, дифференциатор и др.); 

Analog.olb – дискретные аналоговые компоненты (R, C, L, E и др.); 

Sourse.olb – источники аналоговых и цифровых сигналов, параметры 

которых задаются в текстовом виде;   и т.д. 

2. Основные этапы моделирования 

Графический редактор Schematics позволяет создавать чертежи 

принципиальных схем в среде Windows и передавать данные в программы 

моделирования PSpice и параметрической оптимизации PSpice Optimizer. После 

загрузки графического редактора (нажатие на пиктограмму ) выводится 

основной экран (Рис. 1). Схема может располагаться на одной или нескольких 

страницах. В центре верхней строки экрана размещается имя файла текущей 

схемы и номер страницы. После номера страницы в скобках указывается 

состояние схемы: simulation – выполнение моделирования; simulation error – 

ошибки, возникшие при моделировании; current – отсутствие изменений в схеме 

после выполнения моделирования; stale – измененная схема. 

В нижней части экрана размещается строка состояний. В ней слева указаны 

текущие координаты курсора X, Y в выбранной системе единиц (устанавливается 
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по команде Options > Page Size). Справа указывается имя текущей подкоманды, а 

посередине - строка сообщений с краткими указаниями по выполнению текущей 

команды. 

 

Рис. 1. Экран редактора PSpice Schematics в режиме редактирования схем 

Редактор Schematics управляется с помощью системы ниспадающих меню и 

пиктограмм. 

Вначале нужно выбрать курсором команду File, после чего в ниспадающем 

меню выбрать строку New (или щелкнуть по пиктограмме   ), если 

создается новая схема, или строку Open (пиктограмма         ), если загружается 

существующая схема. 

Символы компонентов наносятся на схему по команде Draw > Get New Part 

или выбором пиктограммы , а проводники - по команде Draw > Wire (или 

выбором пиктограммы  ). После этого щелчком мыши редактируются 

параметры компонентов. Все компоненты характеризуются списком атрибутов 

(параметров), который открывается двойным щелчком по любой точке, 
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находящейся внутри изображения символа компонента (или щелчком мыши 

выбрать компонент, а затем выполнить команду Edit > Attribute). На рис. 2 в 

качестве примера приведен список атрибутов независимого источника 

синусоидального напряжения, который характеризуется значением ЭДС при 

расчете режима по постоянному току (DC), комплексной амплитудой (АС) при  

 

Рис. 2. Диалоговое окно редактирования атрибутов источника 

анализе частотных характеристик и параметрами синусоидального сигнала 

(постоянная составляющая voff, амплитуда vampl, частота freq и т.д.), 

применяемого при расчете переходных процессов. 

На панели атрибутов редактируется любой параметр, не помеченный 

символом «*». Однако параметры, отображаемые на схеме, удобнее 

редактировать индивидуально, дважды щелкнув по нему на схеме курсором. В 

результате откроется панель редактирования, пример которой приведен на рис. 3. 

 

Рис. 3. Редактирование сопротивления резисторов 
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2.1. Подготовка схемы к моделированию 

1) Перед моделированием схемы всем ее компонентам необходимо 

присвоить уникальные имена, так называемые позиционные обозначения 

(команда Tools > Annotate). 

2) По команде Analysis > Electrical Rule Check проверить наличие в схеме 

неподсоединенных выводов компонентов, совпадающих позиционных 

обозначений и др. Перечень ошибок просматривается по команде File > 

View Messages. 

3) Составить задание на моделирование по команде Analysis > Setup или 

щелкнув по пиктограмме    . В открывшемся окне (рис. 4) 

нажатием курсора отмечают нужные директивы моделирования и 

нажатием соответствующей кнопки открывают диалоговые меню задания 

директив. 

 

 

 

 

 

 

 

 

 

 

Рис. 4. Выбор директив моделирования 

 

AC Sweep – расчет частотных характеристик и уровня шума; 

Load Bias Point – загрузка данных режима по постоянному току; 

Save Bias Point – сохранение данных режима по постоянному току; 

DC Sweep – вариация параметров при расчете режима по постоянному току; 
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Monte Carlo/Worst Case – статистический анализ по методу Монте-Карло и 

наихудший случай; 

Bias Point Detail – вывод подробной информации о режиме по постоянному 

току; 

Digital Setup – задание параметров цифровых устройств; 

Options – параметры моделирования; 

Parametric – многовариантный анализ; 

Sensitivity – чувствительность в режиме по постоянному току; 

Temperature – вариация температуры; 

Transfer Function – передаточные функции по постоянному току; 

Transient – расчет переходных процессов. 

В качестве примера на рис. 5 изображена панель задания параметров 

директив расчета переходных процессов. 

 

Рис. 5. Установка параметров директив моделирования переходных 

процессов 
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4)  В заключение по команде Analysis > Create Netlist создаются список 

соединений схемы и задание на моделирование, которые заносятся в три файла с 

расширениями имен *.als, *.net, *.cir. 

Примечание. Из перечисленных выше пунктов обязательно выполнить 

только п. 3 - установку параметров моделирования. Остальные пункты 

выполняются автоматически после запуска режима моделирования. 

 

 

 

2.2. Программа моделирования PSpice 

Программа моделирования PSpice запускается командой Analysis > 

Simulation или щелчком мыши по пиктограмме     . В системе OrCAD 9.2 

программа моделирования PSpice объединена с программой отображения и 

обработки результатов моделирования Probe. Результаты моделирования, 

полученные с помощью PSpice, заносятся в файлы данных для построения 

графиков и передаются в Probe. Программа Probe вызывается автоматически 

после завершения моделирования в PSpice. Управляющая оболочка программ 

приведена на рис. 6. 
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Рис. 6. Экран программ PSpice и Probe 

 

Расположенная в центре основная часть экрана предназначена для вывода 

результатов моделирования в графическом или текстовом виде на нескольких 

закладках. В левой нижней части экрана приводится информация о прохождении 

этапов моделирования. В правой нижней части имеются три закладки последнего 

сеанса моделирования: 

 Analysis – детальная информация о ходе моделирования; 

 Watch – вывод текущих значений напряжений узлов, помеченных на 

схеме символами WATCH1 (из библиотеки Special); 

 Devices – статистика состава компонентов проекта. 

Кроме того, в программе Probe пользуются следующими суффиксами для 

простановки единиц размерности на осях координат: 
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V – вольты             d – градусы 

А – амперы            s – секунды 

W – ватты              Н – герцы 

В программе Probe также определено, что W=V·A, V=W/A, A=W/V. Так что 

если построить график выражения V(5)*ID(M13), то ось ординат автоматически 

будет размечена в ваттах. 

 

Основные фазы работы с программой Probe. 

1. Загрузка. Программа Probe загружается под управлением PSpice 

Schematics или автономно. В последнем случае после появления основного экрана 

программы по команде File > Open загружается файл данных с результатами 

моделирования. При моделировании нескольких режимов предлагается выбрать 

один из них (рис. 7). 

 

 

 

Рис. 7. Выбор режима моделирования 

 

В файл данных помещаются сообщения об ошибках, выявленных при 

моделировании цифровых устройств. Программа Probe выводит сообщение об их 

количестве и предлагает просмотреть их на экране (выбор кнопки ОК) или 

пропустить (Cancel). 

2. Построение графиков. После выбора команды Trace > Add Trace или 

щелчком по пиктограмме  открывается окно выбора переменных (рис. 8). 

Типы переменных, перечень которых приведен в окне, определяются положением 

выключателей: 



 13 

 

Рис. 8. Окно выбора переменных 

Analog – аналоговые переменные; 

Digital – цифровые переменные; 

Voltages – напряжения; 

Currents – токи; 

Noise (V²/Hz) – спектральная плотность напряжения выходного шума; 

Alias Names – псевдонимы; 

Subcircuit Nodes – внутренние узлы макромоделей (только напряжения). 

Переменные помечаются курсором, и их имена переносятся в командную 

строку Trace Expression. В расположенном справа окне Functions or Macros 

можно выбрать математические функции и макросы. Так можно выбрать 

несколько переменных и отредактировать образованную строку для записи 

математических выражений. Графики строятся после нажатия кнопки ОК. 

На экран выводится координатная сетка графика, по горизонтальной оси 

которого откладывается независимая переменная, соответствующая выбранному 
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режиму, например Time. На экране может располагаться несколько окон, в 

каждом из которых строится несколько графиков. На одном графике можно 

поместить несколько кривых, которые на цветном мониторе выделяются цветом, 

а при выводе на черно-белый монитор, принтер или графопостроитель – 

различными значками. 

В строке Trace Expression можно указать имя оной или нескольких 

переменных или выражений. При вводе имени только одной переменной на оси Y 

автоматически проставляются единицы измерений в соответствии с типом 

переменной. 

На график можно вывести не только значения отдельных переменных, но и 

математические выражения, в которых допускаются следующие операции: 

+, –, *, /  – арифметические операции; 

ABS(x) – |x|, абсолютное значение х; 

SGN(x) – знак числа х (+1 при х>0, 0 при х=0 и -1 при х<0); 

SQR (x) – √х, корень квадратный из х; 

EXP(x) – exp(x), экспонента числа х; 

LOG(x) – ln(x), натуральный логарифм х; 

LOG10(x) – log(x), десятичный логарифм х; 

M(x) – модуль комплексной переменной х; 

P(x) – фаза комплексной переменной х (в градусах); 

R(x) – действительная часть комплексной переменной х; 

IMG(x) – мнимая часть комплексной переменной х; 

G(x) – групповое время запаздывания комплексной переменной х (в 

секундах); 

PWR(x,y) – |х|
y
, степенная функция; 

SIN(x) – sin(x), синус х (х в радианах); 

COS(x) – cos(x), косинус х (х в радианах); 

TAN(x) – tg(x), тангенс х (х в радианах); 

ATAN(x), ARCTAN(x) – arctg(x), арктангенс х (х в радианах); 
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d(y) – производная от переменной y по переменной, откладываемой по оси х; 

s(y) – интеграл от переменной у по переменной, откладываемой по оси х; 

AVG(y) – текущее среднее значение переменной y; 

AVGX(y, d) – текущее среднее значение переменной y на отрезке оси х 

длины d; 

RMS(y) – текущее среднеквадратическое отклонение переменной y; 

DB(x) – значение переменной х в децибелах; 

MIN(x) – минимальное значение вещественной части переменной х; 

MAX(x) – максимальное значение вещественной части переменной х. 

3. Электронный курсор. Координаты точек на графиках считываются с 

помощью двух электронных курсоров. Дисплей переключается в режим 

считывания координат по команде Trace > Cursor > Display или щелчком по 

пиктограмме  . В правом нижнем углу экрана располагается окно, в 

котором отображаются текущие координаты двух курсоров и расстояние между 

ними по двум осям координат. Курсоры могут быть связаны с одним или двумя 

графиками аналоговых переменных. Одновременно на временных диаграммах 

считываются логические состояния всех цифровых переменных. В первый момент 

времени оба курсора помещены в начало первого аналогового графика. Первый 

курсор перемещается с одной кривой на другую нажатием клавиш Ctrl+4 и 

Ctrl+6, второй -Shift+Ctrl+4 и Shift+Ctrl+6. Первый курсор перемещается вдоль 

выбранной кривой с помощью клавиш «←» и «→». Каждое нажатие на эти 

клавиши приводит к перемещению курсора по графику на один пиксель. 

Манипулятор мышь также может управлять курсорами: левая кнопка управляет 

первым курсором, правая-вторым. 

В меню Cursor имеются команды управления положением курсора: Peak, 

Trough, Slope, Min, Max, Point и Search Commands. Эти команды изменяют 

положение того курсора, который с помощью функциональных клавиш или мыши 

перемещался последним. Если до их выполнения оба курсора не перемещались, 

то эти команды изменяют положение первого курсора. 
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Приведем определение этих команд. 

Peak – перемещение курсора к следующему пику (с обеих сторон от 

пика имеется хотя бы по одной точке с меньшим значением Y); 

Trough  – перемещение курсора к следующей впадине (с обеих сторон 

от нее имеется хотя бы по одной точке с большим значением Y); 

Slоpe    – перемещение курсора к следующему максимуму огибающей 

(огибающие могут быть как положительными, так и отрицательными). 

Курсор обычно перемешается к точке, находящейся посредине между соседними 

точками данных; 

Min – перемещение курсора к точке на графике, имеющей 

минимальное значение Y; 

Max – перемещение курсора к точке на графике, имеющей 

максимальное значение Y; 

Point  – перемещение курсора к точке следующего отсчета; 

Search Commands – ввод одной или нескольких команд для поиска 

определенной точки на графике и перемещения в нее курсора. 

4. Нанесение меток на графики. По команде Tools > Label на графики 

аналоговых переменных наносятся метки в виде текстовых или графических 

символов, которые представляют собой отрезки линий, линейно-ломанные линии, 

стрелки, прямоугольники, окружности и эллипсы. Метки наносятся с помощью 

мыши. Методика нанесения всех меток одинакова: сначала в определенной точке 

поля графика щелчком левой кнопки мыши фиксируется начальный элемент 

метки и относительно него наносится остальная часть текстовой или графической 

метки. Например, при нанесении линии сначала фиксируется ее начало, затем 

перемещается и фиксируется ее окончание, соединенное с начальной точкой 

«резиновой» нитью. Повторный щелчок кнопкой мыши фиксирует метку. 

Нажатие правой кнопки мыши или клавиши Esc отменяется нанесение метки. 

В программе Probe возможны также: создание и редактирование макросов 

(Trace > Macro); вычисление целевых функций и выражений их содержащих 
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(Trace > Eval Goal Function            );  преобразование Фурье всех функций, 

графики которых выделены на экране дисплея (Plot > Axis Settings опция 

Processing Options > Fourier); изменение имени переменной откладываемой по 

оси Х (Plot > Axis Settings, опция Axis Variabl), что позволяет построить 

зависимость одной переменной, откладываемой по оси Y, от другой переменной, 

откладываемой по оси Х. 
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