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COMSOL MULTIPHISICS 

 

COMSOL Multiphysics is a finite element analysis, solver and Simulation 

software / FEA Software package for various physics and engineering applications, 

especially coupled phenomena, or multiphysics. COMSOL Multiphysics also 

offers an extensive interface to MATLAB and its toolboxes for a large variety of 

programming, preprocessing and postprocessing possibilities. The packages are 

cross-platform (Windows, Mac, Linux). In addition to conventional physics-based 

user interfaces, COMSOL Multiphysics also allows for entering coupled systems 

of partial differential equations (PDEs). The PDEs can be entered directly or using 

the so-called weak form (see finite element method for a description of weak 

formulation). An early version (before 2005) of COMSOL Multiphysics was called 

FEMLAB.  

COMSOL was started by graduate students to Germund Dahlquist based on 

code developed for a graduate course at the Royal Institute of Technology (KTH) 

in Stockholm, Sweden. 

In the chapter we will consider how to simulate Generator in 2D. This 

example shows how the circular motion of a rotor with permanent magnets 

generates an induced EMF in a stator winding. The generated voltage is calculated 

as a function of time during the rotation. The model also shows the influence on 

the voltage from material parameters, rotation velocity, and number of turns in the 

winding. 
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The center of the rotor consists of annealed medium carbon steel, which is a 

material with a high relative permeability. The center is surrounded with several 

blocks of a permanent magnet made of samarium and cobalt, creating a strong 

magnetic field. The stator is made of the same permeable material as the center of 

the rotor, confining the field in closed loops through the winding. The winding is 

wound around the stator poles. Figure shows the generator with part of the stator 

sliced in order to show the winding and the 

rotor. 

Figure: Drawing of a generator showing 

how the rotor, stator, and stator winding are 

constructed. The winding is also connected 

between the loops, interacting to give the 

highest possible voltage. 

 

Modeling in COMSOL Multiphysics 

The COMSOL Multiphysics model of the generator is a time-dependent 2D 

problem on a cross section through the generator. This is a true time-dependent 

model where the motion of the magnetic sources in the rotor is accounted for in the 

boundary condition between the stator and rotor geometries. Thus, there is no 

Lorentz term in the equation, resulting in the PDE 

1
0

t



 

     

A
A  

where the magnetic vector potential only has a z component. 

Rotation is modeled using a deformed mesh application mode (ALE), in which the 

center part of the geometry, containing the rotor and part of the air-gap, rotates 

with a rotation transformation relative to the coordinate system of the stator. The 

rotation of the deformed mesh is defined by the transformation 
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The rotor and the stator are drawn as two separate geometry objects, so it is 

possible to use an assembly (see “Using Assemblies” on page 405 of the COMSOL 

Multiphysics Modeling Guide for further details). This has several advantages: the 

coupling between the rotor and the stator is done automatically, the parts are 

meshed independently, and it allows for a discontinuity in the vector potential at 

the interface between the two geometry objects (called slits). The rotor problem is 

solved in a rotating coordinate system where the rotor is fixed (the rotor frame), 

whereas the stator problem is solved in a coordinate system that is fixed with 

respect to the stator (the stator frame). An identity pair connecting the rotating 

rotor frame with the fixed stator frame is created between the rotor and the stator. 

The identity pair enforces continuity for the vector potential in the global fixed 

coordinate system (the stator frame). 

The material in the stator and the center part of the rotor has a nonlinear relation 

between the magnetic flux, B and the magnetic field, H, the so called B-H curve. 

In COMSOL Multiphysics, the B-H curve is introduced as an interpolation 

function; see Figure 3-3. The function can be used in the subdomain settings. 

Usually B-H curves are specified as |B| versus |H|, but the perpendicular waves 

application mode must have |H| versus |B|. It is therefore important that the H-data 

is entered as f(x)-data of the interpolation function and the B-data entered as x-data. 

This relationship for |H| is predefined for the material Soft Iron (without losses) 

in the materials library that is shipped with the AC/DC Module, acdc_lib.txt. 
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Figure : The norm of the magnetic flux, |B|, versus the norm of the magnetic field, 

|H|, for the rotor and stator materials. The inverse of this curve is used in the 

calculation. 

The generated voltage is computed as the line integral of the electric field, E, along 

the winding. Because the winding sections are not connected in the 2D geometry, a 

proper line integral cannot be carried out. A simple approximation is to neglect the 

voltage contributions from the ends of the rotor, where the winding sections 

connect. The voltage is then obtained by taking the average z component of the E 

field for each winding cross-section, multiplying it by the axial length of the rotor, 

and taking the sum over all winding cross sections. 
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where L is the length of the generator in the third dimension, NN is the number of 

turns in the winding, and A is the total area of the winding cross-section. 
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The generated voltage in the rotor winding is a sinusoidal signal. At a rotation 

speed of 60 rpm the voltage will have an amplitude around 2.3 V for a single turn 

winding; see Figure. 

 

 

Figure: The generated voltage over one quarter of a revolution. This simulation 

used a single-turn winding. 
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The norm of the magnetic flux, |B|, and the field lines of the B field are shown 

below in Figure at time 0.20 s. 

 

Figure : The norm and the field lines of the magnetic flux after 0.2 s of rotation. 

Note the brighter regions, which indicate the position of the permanent magnets in 

the rotor. 

Model Library path: ACDC_Module/Motors_and_Drives/generator_2d 

Modeling Using the Graphical User Interface 

MODEL NAVIGATOR 

1. In the Model Navigator, make sure that 2D is selected in the Space 

dimension list. 

2. In the AC/DC Module folder, select Rotating Machinery>Rotating 

Perpendicular Currents. 

3. Click OK to close the Model Navigator. 

OPTIONS AND SETTINGS 
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1. From the Options menu, choose Constants. 

2. In the Constants dialog box, define the following constants with names and 

expressions.The description field is optional. When done, click OK.  

 

When you enter the constant t in the table, the text turns red. The reason is that t is 

the reserved variable name for time in COMSOL Multiphysics. However, because 

of the solution procedure in this model—you first compute a stationary solution 

which you then use as the initial condition for a subsequent time-dependent 

simulation—t needs to be given a value (zero) also for the stationary case. It will 

subsequently be overridden by the t values from the transient solver. 

GEOMETRY MODELING 

The geometry modeling of this model is rather extensive, so you can choose to 

import the generator geometry from a binary file. Select the section that you prefer. 

Importing the Geometry from a Binary File 

1. From the File menu, select Import>CAD Data From File. 

2. In the Import CAD Data From File dialog box, make sure that either All 2D 

CAD files or COMSOL Multiphysics file is selected in the Files of type list. 

3. From the COMSOL Multiphysics installation directory, go to the model 

library path given on page 46. Select the generator_2d.mphbin file, and click 

Import. 

4. Skip the section “Creating the Geometry from Scratch” and continue at 

“Assemble the Geometry” on page 50. 

Creating the Geometry from Scratch 

Please follow the steps in the geometry modeling carefully. The instructions in the 

following sections assume that the boundary numbering is that resulting from these 
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steps. After all geometry operations and the assembly step, there should be a total 

of 152 boundaries 

 

1. Choose Draw>Specify Objects>Circle to create circles with the following 

properties: 

 

2. Choose Draw>Specify Objects>Rectangle to create rectangles with the 

following properties: 

 

3. Open the Create Composite Object dialog box from the Draw menu or 

click on the toolbar button with the same name. 

4. In the dialog box clear the Keep interior boundaries check box. 

5. Type C2+C1*(R1+R2+R3+R4) in the Set formula edit field. 

6. Click OK. 

7. Open the Create Composite Object dialog box again and select the Keep 

interior boundaries check box. 

8. Type C4+CO1-C3 in the Set formula edit field. 

9. Click OK. 

10.  Create two new circles according to the table below. 
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11.  Click the Zoom Extents button to get a better view of the geometry. 

12.  Select the circles C1 and C2. 

13.  Press Ctrl+C to copy the circles. 

14.  Press Ctrl+V to paste the circles. Make sure that the displacements are zero 

and click OK. 

15.  Go to Draw>Modify>Rotate and type 45 in the Rotation angle edit field 

before clicking OK. 

16.  Repeat the last two steps but with rotation angles 90, 135, 180, −45, −90, 

and−135. 

17.  Select all objects by pressing Ctrl+A, then click the Union toolbar button. 

18.  Create four circles with the following properties: 

 

19.  Create four rectangles with the following properties: 

 

20.  Open the Create Composite Object dialog box and clear the Keep interior 

boundaries check box. 

21.  Type C2+C1*(R1+R2+R3+R4) in the Set formula edit field. 

22.  Click OK. 
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23.  Open the Create Composite Object dialog box again and select the Keep 

interior boundaries check box. 

24.  Type CO2+C3+C4 in the Set formula edit field. 

25.  Click OK. 

The geometry in the drawing area should now look like that in Figure. 

 

Figure: Generator geometry. 

Assemble the Geometry 

1. Open the Create Pairs dialog box from the Draw menu. 

2. Select both objects (CO1 and CO3), and click OK. 

You have now created two separate geometry objects in an assembly. You have 

also created an identity pair connecting the physics in the rotor and the stator, 

taking the rotation into account. An interface between two assemblies is actually 

two groups of overlapping boundaries that are, without the pair connection, 

completely separated in terms of mesh and solution variables. This is necessary to 
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allow a sliding mesh at the interface between the stator and rotor where the 

solution variable becomes discontinuous across that interface. 

PHYSICS SETTINGS 

1. From the Options menu point to Integration Coupling Variables and click 

Subdomain Variables. 

2. In the Subdomain Integration Variables dialog box define a variable with 

integration order 4 and global destination according to the following table: 

 

3. Click OK. 

Steps 4–6 below are only necessary to check that the library you need is loaded 

and to view the interpolation function of one of the materials in this library. 

These steps can be skipped if you know that you have the library loaded. If you 

later notice that you are missing this library, just go back to these steps and add 

the library. 

4. Open the Options menu and select Materials/Coefficients Library. 

5. Make sure that the library acdc_lib.txt is loaded (click the minus in front of 

other libraries to remove their content from the view). If you cannot find the 

library, load the library by clicking the Add Library button. The file should 

be located under the data folder in the COMSOL installation directory. 

6. Click OK to close the Materials/Coefficients Library dialog box. 

Subdomain Settings 

1. From the Multiphysics menu, select Perpendicular Induction Currents, 

Vector Potential (emqa) if it is not already selected. 

2. Choose Physics>Properties. 

3. In the Application Mode Properties dialog box, choose On from the Weak 

constraints list. The ideal weak constraints help conserving the magnetic flux 

across the assembly boundaries between the rotor and the stator. This allows 
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you to specify an absolute tolerance for this entity when solving the time-

dependent model. 

4. Click OK. 

5. From the Physics menu open the Subdomain Settings, then select any entry 

in the Subdomain selection list. 

6. Click the Load button to open the Materials/Coefficients Library dialog 

box. 

7. In the dialog box select the Soft Iron (without losses) material from 

theElectric (AC/DC) Material Properties library. 

8. Click Apply. The material Soft Iron (without losses) has now been added to 

the model. You see which materials you have added to the model under the 

Model item in the Materials tree view. 

9. Repeat the last two steps for the materials Samarium Cobalt (Radial, 

inward) and Samarium Cobalt (Radial, outward). Before you close the 

dialog box, make sure that you see all three materials under Model in the 

Materials tree view. 

10.  Click Cancel to close the Materials/Coefficients Library dialog box. 

11.  Enter subdomain settings and select materials according to the table below. 

To change the constitutive relation, 

 

12.  Click OK. 

13.  From the Multiphysics menu select Moving Mesh (ALE) (ale). 

14.  From the Physics menu open the Subdomain Settings. 

15. Select Subdomains 19–28, then select the predefined group rotate_CCW 

from the Group list. 
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This group uses a prescribed displacement with expressions that define 

counterclockwise rotation around the origin. The default setting for all other 

subdomains is no displacement. 

16.  Click OK to close the dialog box. 

Boundary Conditions 

Leave the boundary settings at their defaults. The identity pair creates a coupling 

between the rotor and the stator in the ALE frame. 

MESH GENERATION 

1. From the Mesh menu, open the Free Mesh Parameters dialog box. 

2. From the Predefined mesh sizes list, select Finer. 

3. Click the Custom mesh size option button and type 2 in the Resolution of 

narrow regions edit field. 

4. Click Remesh to generate the mesh. 

5. Click OK to close the dialog box. 

COMPUTING THE SOLUTION 

Begin by computing the initial solution for the subsequent time-dependent 

simulation. 
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1. Open the Solver Parameters dialog box by clicking the corresponding button 

on the Main toolbar or from the Solve menu.  

2. With the Auto select solver check box selected, select Static from the 

Analysis list. 

3. Click OK. 

4. Click the Solve button. 

Next, simulate the generator with the rotor in motion. By default, the solution you 

just calculated will be used as the initial solution. 

1. Open the Solver Parameters dialog box again and select Transient from the 

Analysis list. 

2. 2In the Times edit field type range(0,0.01,0.25), and in the Absolute 

tolerance edit field type Az 1e-3 lm1 5e3. 
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3. Click OK. 

4. Click the Restart button. 

POSTPROCESSING AND VISUALIZATION 

1. From the Postprocessing menu, open the Plot Parameters dialog box. 

2. On the General page, select the solution for time 0.2 s from the Solution at 

time list. Clear the Geometry edges check box. 

3. On the Surface page select Magnetic flux density, norm from the 

Predefined quantities list or type normB_emqa in the Expression edit field. 

4. On the Contour page type Az in the Expression edit field and type 15 in the 

Levels edit field. Click to select the Contour plot check box. 

5. In the Contour color area click the Uniform color option button, and clear 

the Color legend check box. 

6. Click the Color button and select a black color. Click OK to close the 

Contour Color dialog box. 

7. On the Boundary page type 1 in the Expression edit field. Click to select the 

Boundary plot check box. 

8. In the Boundary color area click the Uniform color option button. 

9. Click the Color button and select a black color. Click OK to close the 

Boundary Color dialog box. 

10.  Click OK to close the Plot Parameters dialog box. 
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To view the induced voltage as a function of time, proceed with the steps below. 

1. From the Postprocessing menu, select Domain Plot Parameters. 

2. On the Point page select an arbitrary point in the Point selection list, then 

type Vi*NN in the Expression edit field. 

3. Click OK. 

To create an animation of the rotating rotor, do the following steps. 

1. Open the Plot Parameters dialog box. 

2. Click the Animate tab and make sure that all time steps are selected. 

3. Click the Start Animation button. When the movie has been generated, the 

COMSOL Movie Player opens it. 

 

 


