
Общие принципы создания моделей в COMSOL 
 
 

Порядок решения.  

1. Выбираем размерность модели, определяем физический раздел в Model Navigator 
[Навигаторе моделей] (каждому разделу соответствует определенное 
дифференциальное уравнение) и определяем стационарный или нестационарный 
анализ температурного поля.  

2. Определяем рабочую область и задаем геометрию  
3. Задаём исходные данные, зависимости переменных от координат и времени  
4. Указываем теплофизические свойства и начальные условия  
5. Указываем граничные условия  
6. Задаём параметры и строим сетку  
7. Определяем параметры решающего устройства и запускаем расчет.  
8. Настраиваем режим отображения  
9. Получаем результаты  

1. Навигатор моделей и главное меню 

•  Выбирая размерность модели, следует помнить, что просто задание сетки в трехмерной 
модели может занимать десятки минут даже на мощном компьютере. Для большинства 
трехмерных задач имеет смысл сначала задать и рассчитать двумерную модель, а уже 
потом при необходимости повторить расчет для трехмерной модели. Тем более, что если 
вы не импортируете геометрию из внешней CAD системы, а задаете непосредственно в 
FEMLAB , то гораздо удобнее получить трехмерную модель, преобразованием 
соответствующей двумерной. Размерность модели выбирается в Model Navigator 
[Навигаторе моделей] на первой вкладке New в Space Dimension [размерность 
пространства] , кроме 1D , 2D и 3D там есть Axial Symmetry (1D) и (2D) для 
осесимметричных моделей.  

•  Теперь выбираем физический раздел, в рамках данного пособия рассмотрены три 
раздела Heat Transfer [Теплоперенос] , Fluid Dynamics [Гидродинамика] и Diffusion 
[Диффузия] и модуль расширения General Heat Transfer [Общий теплоперенос] . 
Раздел Fluid Dynamics использует уравнение Навье-Стокса для несжимаемой жидкости. 
Раздел Heat Transfer включает в себя, кроме подраздела Conduction [Кондукция] , 
подраздел Convection and Conduction [Конвекция и кондукция] , который отличается 
тем, что кроме теплофизических свойств, можно задать поле скоростей теплоносителя. 
Раздел Diffusion тоже состоит из двух подразделов: Diffusion [Диффузия] и Convection 
and Diffusion [Конвекция и диффузия] . Один из модулей расширения General Heat 
Transfer [Общий теплоперенос] включает в себя объединенные с излучением, 
конвекцию и кондукцию, а так же разделы, Thin Conductive Layer – тонкий 
теплопроводный слой, Bioheat equation – режим расчета тепломассопереноса в живых 
тканях, Non - Isotermal Flow – неизотермический поток.  

Чтобы создать мультифизические модели, например, поток жидкости в канале: надо 
нажать кнопку Multiphisics , затем нажимается кнопка Add geometry [Добавить 
геометрию] , в открывшемся окне выбирается размерность и названия осей. После выбора 
геометрии, нажимается кнопка Add… [Добавить] и сначала выбирается один физический 
раздел (Heat Transfer > Convection and Conduction), а потом в модель добавляется 



второй раздел (Fluid Dynamics > Incompressible Navier - Stokes). Между собой они 
взаимодействуют как раз через поле скоростей.  

•  Для каждого из подразделов можно выбрать Steady-state analysis [Стационарный 
анализ] или Transient analysis [Переходный анализ] , впрочем, вид анализа можно 
потом изменить.  

•  Так же на вкладке New в Model Navigator можно выбрать вид конечных элементов, по 
умолчанию стоит Lagrange - Quadratic [Лагранжевы-квадратичные] , предлагаются 
Лагранжевы элементы вплоть до пятой степени, в некоторых разделах доступны элементы 
Эйлера.  

Кроме New , в Model Navigator , есть еще три вкладки. Model Library [Библиотека 
моделей] , в ней расположены примеры моделей для всех физических разделов, 
некоторые из этих моделей присутствуют в данном пособии. User Models 
[Пользовательские модели] , представляет собой отображение папки, в которой хранятся 
модели созданные. Settings [Настройки] позволяют установить язык (при установленном 
русификаторе, даже русский). И изменить фон рабочей области с белого на черный. Там 
же устанавливается система единиц, можно выбрать из десяти вариантов, включая СИ. 
Кроме того в этой версии появилась вкладка Open которая так же как и User Models 
позволяет работать с файлами.  

После нажатия клавиши OK в Model Navigator открывается окно основной программы с 
рабочей областью, инструментальными панелями и главным меню. Кнопки на 
инструментальных панелях повторяют пункты главного меню, поэтому мы рассмотрим 
пункты меню по порядку.  

   

Главное меню.  

File – содержит команды создания, открытия и сохранения файлов, печати, а также 
импорта геометрии из внешних CAD систем и экспорта полученных данных в текстовый 
файл.  

Edit – содержит команды отмены и повторения операций, работы с буфером обмена и 
команды выделения.  

Options – содержит команды задания рабочей области Axes/Grid settings , констант 
Constants , выражений Expression , функций Function , связанных переменных Coupling 
Variables и различные настройки отображения геометрических элементов и масштаба.  

Draw – содержит команды построения и преобразования геометрических объектов, а так 
же команды превращения двумерных объектов в трехмерные.  

Physics – содержит команды задания физических свойств подобластей Subdomain , 
граничных условий Boundary , в том числе периодических ГУ (Граничных Условий) 
Periodic Condition и изменения системы дифференциальных уравнений Equation system .  

Mesh – содержит команды управления конечноэлементной сеткой.  



Solve – содержит очень важные команды управления решающим устройством, можно 
выбрать зависимость от времени, линейность или нелинейность, а так же указать 
множество других параметров решателя.  

Postprocessing – содержит команды для отображения результатов вычислений, во всех 
возможных видах: от векторов и поверхностей уровня, до графиков и интегралов по 
границе.  

Multiphisics – открывает Model Navigator , и позволяет переключаться между 
физическими режимами в мультифизических моделях.  

Help – содержит обширную справочную систему.  

2. Рабочая область и задание геометрии 

Итак, мы открыли окно основной программы: если мы выбрали размерность пространства 
1D , то мы видим рабочую область с координатной осью и кнопками для рисования 
геометрии. В одномерном режиме это кнопки point [точка], line [линия], mirror 

(отображает объект зеркально), move (перемещает объект) и scale (изменяет размер 
объекта). Также в верхней части экрана есть стандартные кнопки для выполнения 
операций с файлом и буфером обмена и кнопки повторяющие основные команды из 

разделов Mesh , Solve и Postprocessing главного меню. В режиме 2D добавляются кнопки 
создания кривых Безье, прямоугольников и овалов, кнопка Array [массив] создающая из 
одного объекта, матрицу объектов любого размера. Кнопка Rotate [вращение] позволяет 
повернуть созданный объект на любой угол. В трехмерном режиме с помощью кнопок 
можно создавать параллелепипеды, эллипсоиды, конусы, цилиндры и шары, а также 

управлять расположением координатных осей и освещением фигуры.  

В первую очередь рекомендуется задать границы отображаемой рабочей области Options 
> Axes/Grid settings [Опции>Установки оси/решетки]. Предположим, что мы работаем 
в двумерном режиме и хотим задать модель объекта с размерами метр на метр. В 
открывшемся окне выбираем вкладку Axis [Оси], галочка Axis equal означает, что оси 
будут равны, то есть один метр по оси Х будет визуально такого же размера как по оси Y . 
Для протяженных объектов эту галочку можно снять, и тогда на экране оси могут быть не 
равны. Это удобно, когда в каком-нибудь из измерений объект непропорционально 
большой.  

 



В разделе x - y limits нужно задать пределы отображения осей, в нашем случае это 0 и 1.1 
для минимума и максимума соответствующих осей. На вкладке Grid [Решетка] можно 
снять галочку Auto и самим установить интервал решетки. Вообще, при построении 
модели можно задавать просто координаты соответствующих фигур (например 
координаты центра окружности и ее радиус), но часто удобнее задать фигуру просто 
отметив эти координаты с помощью мыши, и тогда очень важно чтобы узлы решетки 
совпадали с ключевыми точками фигуры. Поэтому если толщина минимального элемента 
составляет скажем один миллиметр, то целесообразно задать именно такой интервал 
сетки. Галочка Visible позволяет выключить режим отображения. Внизу рабочей области 
можно выключить и привязку мыши к сетке SNAP , но тогда в случае ввода объекта с 
помощью мыши ключевые точки можно будет задать лишь примерно. В области x - y grid 
можно задать в полях x и y spacing интервал решетки по соответствующим осям. Поля 
Extra x и Extra y позволяют добавить любое количество дополнительных линий решетки.  

Внимание: Не стоит путать понятия Grid – решетка и Mesh – сетка конечных 
элементов. Grid служит только для удобства задания геометрии модели и никак не 
влияет на расчеты. От сетки же конечных элементов Mesh напрямую зависит 
точность расчетов.  

 

После задания решетки можно приступить к определению геометрии. Если она у нас 
заранее не создана во внешней CAD программе или не задана в MATLAB (в этих случаях 
она просто импортируется через File > Import ), то придется ее задавать внутренними 
средствами. Предположим, надо нарисовать прямоугольник. Можно воспользоваться 
соответствующими кнопками Rectangle/Square [прямоугольник/квадрат] и 
Rectangle/Square (Centered) [прямоугольник/квадрат (центрированный)], первым 
щелчком отмечается расположение угла или центра, а потом прямоугольник 
растягивается до нужного размера и закрепляется вторым щелчком. При нажатой клавише 
Ctrl создается квадрат. Если нажать на клавишу Shift и щелкнуть на кнопке, то откроется 
окно со всеми параметрами фигуры. Это же окно можно открыть через главное меню: 
Draw > Specify objects .  

Size задает размер объекта с помощью полей Width [ширина] и Height [высота]. 
Rotation angle задаёт угол поворота прямоугольника в градусах.  

Область Position определяет место расположения объекта. Раскрывающийся список Base 
позволяет определить к чему относятся координаты x и y . Corner означает, что мы задаем 
расположение угла прямоугольника (если мы рисуем эллипс, то надо задать координаты 
описанного прямоугольника). Center – мы задаем координаты центра объекта.  



 

Раскрывающийся список Style , предлагает варианты Solid – будет создана целая фигура – 
и Curve – будет создана кривая-контур фигуры. Кривая необходима для создания 
сложной фигуры: сначала задаются кривые, границы объекта, а потом командой Coerce to 
solid выделенные кривые делаются цельной фигурой. В режиме 3D вместо Curve – кривая 
есть понятие Face – оболочка. В поле Name можно вписать имя объекта.  

Несмотря на то, что в окнах Specify objects можно задать точные координаты и размеры 
объектов, часто легче задавать их с помощью мыши, а кривые Безье можно задать только 
с помощью мыши. Вот почему важно заранее определить период решетки.  

При задании сложных фигур приходится задавать десятки элементарных объектов (овалы, 
прямоугольники, кривые Безье, линии, точки) потом их надо объединить или разделить. 
Обычно это делается по физическим признакам, с помощью кнопок Union [объединить], 
Difference [разность], и Intersection [пересечение] или команды Draw > Create 
Composite Object … Эта команда открывает окно, где можно указать из каких элементов 
создается фигура.  

После создания фигуры с помощью кнопки Fillet / Chamfer или одноименного пункта 
меню Draw можно задать фаски или скругления углов. Так же можно размножить фигуру 
с помощью кнопки Array , отразить с помощью Mirror , и изменить размер с помощью 
Scale . Кнопки Rotate и Move поворачивают и сдвигают выделенную фигуру 
соответственно. Все эти кнопки повторяются в виде пунктов меню Draw > Modify .  



 

Для создания трехмерных моделей удобно элементарные фигуры задавать в режиме 3D , а 
более сложные задать сначала в режиме 2D , а потом перенести в трехмерную область.  

Например, мы создали прямоугольник 1 x 0.5 метра. Если его выделить и нажать кнопку 
Draw > Extrude то откроется окно Extrude [Экструзия] где можно задать объект 
подвергающийся операции, название рабочей области (для одной модели можно задать 
несколько рабочих областей, обычно это несколько 2D геометрий и одна составная 3D ). 
Поле Distance определяет на сколько будет растянуто сечение. Если у нас был нарисован 
круг, то после Экструзии будет цилиндр, если сечение рельсы, то будет модель рельсы. 
Scale x и y задают во сколько раз будет изменяться сечение по длине объекта. Если задать 
в эти поля две двойки, то после экструзии (если сечение было круглым) появится 
усеченный конус. Displacement определяет сдвиг верхней плоскости фигуры 
относительно основания. Twist закручивает фигуру вокруг своей оси.  

Draw > Embed скопирует наш двумерный прямоугольник в трехмерную рабочую область. 
По умолчанию в плоскость z =0. Плоскость задается через Draw > work plane settings…  

Draw > Revolve , создаст фигуру вращения. То есть из прямоугольника можно создать 
кольцо с прямоугольным сечением. В открывшемся окне можно задать градусы вращения 
по двум осям и координаты точек вокруг которых будет создаваться фигура вращения.  

Для наглядности, с помощью команды Scene Light можно установить «освещение 
объекта», кнопка Zoom extents поместит фигуру на весь экран.  

3. Функции , константы и выражения .  

Теплофизические параметры могут зависеть от температуры и координат, внешние 
воздействия могут описываться различными функциями, зависящими от времени и 
множества других параметров. В расчетных уравнениях могут присутствовать различные 
константы, при чем значения этих констант могут различаться для разных частей системы 
(например: коэффициент теплоотдачи или коэффициент черноты поверхности).  

В пакете Comsol ( Femlab ) существует мощный инструментарий для работы с 
константами и функциями. Большинство этих команд находится в меню Options. 
Рассмотрим некоторые из них.  



•  Constants [Константы] рекомендуется все применяемые в системе константы вынести 
в эту таблицу, а во всех формулах задавать только буквенное обозначение. Например, 
задать температуру окружающего воздуха Т_air =30, а во всех граничных условиях 
вместо цифры задавать Т_air . Тогда в случае необходимости можно будет поменять одну 
цифру, а не искать по всему меню. Так же список всех часто употребляемых констант 
можно сохранить в отдельный файл и переносить из модели в модель. В последних 
версиях программы появилась возможность – к каждой константе написать Description 
[Примечание], при работе нескольких человек с одной моделью не стоит игнорировать 
эту графу.  

•  Expression [Выражения] содержит Scalar expression [Скалярные выражения], 
Subdomain , Boundary , Edge (только в трехмерном режиме) и Point expression . Можно 
задать зависимость теплофизического параметра от времени t ; координат x , y , z ; от 
безразмерной координаты s (изменяется от 0 до 1 по длине каждой границы) или от 
любых других вычисляемых параметров. Например Q _ ist =100* exp(t). У различных 
элементов системы очень часто одни и те же параметры определяются по разным законам. 
Есть возможность задать одно имя у переменной, например alfa . И открыв Boundary 
expression [Граничные выражения] задать для разных границ, различные формулы 
вычисления alfa . Тогда для всех границ можно будет задать коэффициент теплообмена 
alfa , а программа сама подставит для каждой границы соответствующую формулу.  

•  Couples Variables [Связанные переменные] с помощью этих пунктов меню можно 
задавать очень сложные зависимости между частями системы. Например связать 
граничные условия с интегралом по объему.  

•  Functions [Функция] можно задать свою функцию, причем не только используя 
математические выражения. Если выбрать Interpolation function , то можно задать массив 
параметров и массив значений функций, и по ним построить интерполяционную 
функцию. Можно задать метод интерполяции, есть возможность импортировать данные 
из внешнего файла.  

•  Coordinate systems [Системы координат] можно создать произвольную систему 
координат, с любым расположением осей относительно друг друга.  

•  Material / Coefficients Library [Библиотека материалов] в ней есть возможность 
задать любые физические свойства веществ, и даже их зависимость от параметров 
(температуры и давления).  

•  Visualization / Selection settings [Установки визуализации] позволяют управлять 
отображением объектов, освещением и выделением.  

•  Suppress [Скрытие] В сложных объектах для наглядности иногда нужно сделать 
невидимым какой либо элемент системы. Например, если рассматривается процесс 
конвективного охлаждения, нагляднее, если воздух будет не виден, а будет видна только 
охлаждаемая поверхность с распределением температуры.  

4. Задание теплофизических свойств материалов и начальных условий.  

Когда геометрия задана и все константы определены, можно приступить к заданию 
теплофизических свойств. Для начала открываем меню Physics > Subdomain Settings или 
F8 : откроется окно ввода коэффициентов соответствующих дифференциальных 
уравнений. Для каждого из физических режимов это окно имеет свой вид, и все поля 



будут рассмотрены в соответствующих главах. Здесь же мы рассмотрим только общие для 
всех режимов поля. На рисунке показано это окно для режима Heat Transfer by 
Conduction в трехмерном режиме. Наверху в поле Equation , указано текущее уравнение. 
В поле Subdomain selection , необходимо выбрать область, для которой определяются 
физические свойства. Если областей много, то нужно выделить все созданные из одного 
материала. Чтобы выделить все области надо нажать Ctrl +A .  

 

Во вкладке Physics надо задать свойства материала, в данном случае теплофизические, 
для распространенных материалов можно воспользоваться встроенной библиотекой. В 
нестационарном режиме присутствует поле Time - scaling coefficient [Временной 
коэффициент]. Значение 1 соответствует заданию времени в секундах. Если мы 
рассматриваем процессы идущие значительно больше или меньше чем одна секунда, то 
удобнее задать другой коэффициент и указывать внешние воздействия в соответствующих 
единицах. Для того что бы работать с временем в минутах в это поле надо записать 1/60 , 
если в часах то 1/3600 и т.д.  

Кроме этого можно задать дополнительные параметры объекта. В режиме теплопереноса 
это объемная мощность. В режиме уравнения Навье-Стокса и Конвекции это скорость 
потока по всем осям. В каждом из полей можно вводить математические выражения, 
синтаксис такой же как у MATLAB , но удобнее вводить в поля не формулы, а названия 
переменных, и определять их через Options > Expression .  

В режимах связанных с конвекциях или потоком жидкости во вкладке появляется кнопка 
Artificial Diffusion … [Искусственная диффузия] она позволяет стабилизировать 
решение. Метод конечных элементов подразумевает некоторую дискретизацию 
пространства. При моделировании явлений переноса в сложных объектах это может 
привести к нестабильности решения. Нестабильность можно обнаружить увидев большие 
колебания значений в областях с большими градиентами. Из-за больших колебаний 
решение может несходится. Нажимая Solve > Restart [Решать>Заново] новое решение 
будет отличаться от предыдущего. Методы стабилизации решения основаны на 
добавлении малых слагаемых в дифференциальные уравнения.  

Вкладка Init предназначена для задания начальных условий, в данном случае это 
температура. Вкладка Element позволяет выбрать вид конечных элементов и их 
коэффициенты.  



В последней версии программы COMSOL 3.2 появились вкладки Groups и Color . 
Вкладка Group позволяет распределить различные элементы по группам и менять 
свойства сразу у всей группы. По умолчанию, они раскрашиваются в разные цвета, 
изменить этот режим можно с помощью вкладки Color .  

5.Задание граничных условий и изменение дифференциальных уравнений  

 

Граничные условия задаются через Physics > Boundary Settings или F7. В этом окне надо 
выбрать необходимые границы в поле Boundary selection. Для того, чтобы задать 
температурный перепад на границе двух тел надо сначала включить галочку Interior 
boundaries иначе внутренние границы будут недоступны. Во вкладке Coefficients надо 
выбрать вид граничных условий и указать в соответствующих полях коэффициенты ГУ. 
На рисунке показан пример задания граничного условия третьего рода. В поле Equation 
выводится соответствующее уравнение.  

Как и в окне Subdomain Settings в окне Boundary Settings появились вкладки Groups и 
Color присваивающие границам с различными ГУ разные цвета. В режиме расчета 
теплопереноса излучением в модуле General Heat Transfer , кроме группировки по 
свойствам теплообмена, для экономии вычислительных ресурсов, появляется группировка 
по взаимодействующим границам. То есть принято, что обмениваются излучением 
(«видят друг друга») только границы принадлежащие к одной группе. Эта группа задаётся 
отдельным полем Member of Group(s) во вкладке Boundary Condition .  

В некоторых моделях (в основном связанных с электричеством) кроме свойств на границе 
необходимо задавать свойства ребер и точек. В режиме Fluid Flow>Incompressible 
Navier-Stokes так же необходимо задавать давление в точке.  

Часто при моделировании сложных систем, например радиоэлектронных аппаратов 
кассетного типа, выделяют элементарный объем и проводят расчет для этого 
элементарного объема. Для корректного расчета необходимо задать особый вид 
граничных условий – периодические граничные условия. В программе они задаются с 
помощью команды меню Physics > Periodic Condition . Кроме условий на границе 
Boundary требуется задать периодические свойства для точек Point и в некоторых 
режимах для ребер Edge . Настройки этих окон позволяют задать зависимость 
противоположных границ элементарного объема.  



Для некоторых классов мультифизических задач, где надо связать два объекта с разным 
типом сетки (например, прямоугольную сетку в одной части системы с треугольной в 
другой) и граничными условиями Неймана можно применять условия идентичности 
Physics >Identity Conditions .  

В COMSOL есть много возможностей гибкой настройки системы под каждую конкретную 
задачу. Можно изменять систему Дифференциальных Уравнений в Частных Производных 
( PDE ). Для этого служит группа команд Physics > Equation system . Эти команды 
позволяют в широких пределах изменять исходные PDE , способы задания начальных и 
граничных условий, а также параметры конечных элементов.  

Рассмотрим на примере уравнения теплопереноса. В общем виде нестационарный процесс 
переноса выражается в коэффициентной форме данным уравнением:  

 

В прикладных режимах это уравнение представляется в упрощенном виде без лишних 
членов. Например, нестационарное уравнение теплопроводности (режим Heat Transfer > 
Conduction ) выглядит так:  

 

То есть Ca , альфа , бета , гамма и a равны нулю. C учетом конвекции в режиме Heat 
Transfer > Convection and Conduction добавляется коэффициент альфа=ро*Cp*u (где u 
поле скоростей) и уравнение выглядит так:  

 

Для быстропротекающих тепловых процессов, где закон Фурье уже не работает, 
добавляется коэффициент Сa со второй производной по времени от температуры, 
стандартный прикладной режим теплопереноса его учитывать не будет.  

Чтобы самостоятельно добавить значения необходимых коэффициентов открываем окно 
Physics > Equation system > Subdomain settings или Ctrl + F8 , здесь можно для каждой 
области ( Subdomain ) задать в прямом виде значение любого коэффициента PDE или же 
изменить формулу вычисления коэффициентов. У каждой области для которой мы 
примем изменения, появится значок замка. Он будет виден и из окна Physics > Subdomain 
settings . Приоритет всех значений у окна Physics > Equation system > Subdomain settings 
, поэтому надо проверять какие коэффициенты уже здесь указаны, а лишь потом задавать 
материальные свойства в Physics > Subdomain settings . Сбросить все изменения системы 
уравнений можно кнопкой Reset Equation .  

Для изменения формул ГУ служит окно Physics>Equation system>Boundary settings или 
Ctrl+F7 . Работа с ним аналогична предыдущему.  



С помощью команды Physics > ODE settings в COMSOL можно добавить любые 
Обыкновенные Дифференциальные Уравнения.  

6. Построение сетки 

После задания всех свойств и граничных условий наступает очередь построения сетки. 
Для простейших моделей, на первом этапе оценочного расчета можно задать сетку по 
умолчанию Mesh > Initialize Mesh (или кнопка с изображением треугольника) и 
несколько раз нажать Mesh > Refine mesh и получив достаточно мелкую сетку 
приступить к решению. Для моделей чистой кондукции, не связанных с потоком массы 
,можно этим и ограничиться: для более мелких элементов сетки система автоматически 
произведет сгущение, а если необходимо в какой-либо части системы еще более сгустить 
сетку, то можно нажать кнопку Refine selection и указать нужную область. В одномерном 
и двумерном стационарном режиме можно посоветовать просто делать наиболее мелкую 
сетку – скорость вычисления на современных компьютерах все равно будет приемлемой. 
Вообще, рекомендуется строить сетку такой густоты, чтобы между любыми двумя 
границами было не меньше десяти конечных элементов. В моделях учитывающих 
конвекцию надо всегда помнить, что размер конечного элемента должен быть в несколько 
раз меньше толщины пограничного слоя иначе решение может не сойтись и будет в 
любом случае нестабильно.  

 

По умолчанию, COMSOL строит в двумерном режиме треугольную, а в трехмерном 
тетраэдрическую сетку. Для задания параметров сетки надо выбрать Mesh > Mesh 
parameters или нажать F 9 . Откроется окно настроек, на вкладке Global можно выбрать 
один из предустановленных режимов. В списке Predefined mash sizes девять режимов от 
Extremely fine [Чрезвычайно точный] до Extremely coarse [ Чрезвычайно грубый] , 
остальные расположены между этими крайними режимами. В полях можно задать 
собственные значения параметров сетки. Maximum element size задает максимальный 
размер элемента. По умолчанию равен 1/15 максимальной стороны, задавать его 
необязательно. Maximum element size scaling factor если ничего не задавать в 
предыдущее поле, то значение этого поля будет определять размер элемента (если задать 
0.5 , то размер элемента будет равнятся 1/30 максимальной стороны, если 0.1 то 1/150). 
Element growth rate [ Темп роста элемента] отвечает за степень сгущения, принимает 
значения от единицы до бесконечности, чем ближе значение к единице тем более 



равномерная сетка. Mesh curvature factor и Mesh curvature cut off чем меньше эти 
значения, тем более точно задана криволинейность границы: при больших значениях этих 
параметров вместо кривой будет считаться ломанная линия. Resolution of narrow regions 
задает минимальное количество элементов по самой короткой границе, для точных 
вычислений рекомендуется устанавливать значения этого параметра не меньше десяти.  

Поле Mesh geometry to level позволяет выбрать отдельно создание сетки для областей, 
поверхностей и ребер. Для большинства задач тепломассопереноса это значение должно 
быть областью Subdomain . Refinement method принимает два значения Regular и 
Longest и отвечает за режим работы команды Refine mesh . Если установлено значение 
Regular при нажатии этой команды каждый элемент делится на четыре части в 2 D 
режиме, и на восемь в 3 D . Значение Longest , делит каждый элемент на две части по 
самой длинной стороне. Вкладки Subdomain , Boundary , Edge и Point позволяют задать 
размер элемента для соответствующих элементов модели. Вкладка Advanced позволяет 
задать анизотропию сетки.  

Кнопка Remesh перестраивает сетку с новыми параметрами.  

В двумерном режиме для объектов близких к прямоугольным, можно задать 
четырехугольную сетку с помощью пункта меню Mesh>Map mesh или Ctrl+F9 .  

В разделе Рабочая область и задание геометрии мы рассмотрели способы преобразования 
двумерных моделей в трехмерные с помощью команд Draw > Extrude и Draw > Revolve . 
Тогда после задания трехмерной геометрии придется заново строить сетку из тетраэдров, 
что может занимать значительное время. Иногда целесообразно сначала построить сетку в 
2 D режиме (треугольную или четырехугольную), а потом с помощью команд Mesh > 
Extrude Mesh … растянуть фигуру с сеткой или Mesh > Revolve Mesh … раскрутить 
фигуру с сеткой. Тогда элементы будут не тетраэдрические, а в виде параллелепипедов 
или призм. Время построения такой сетки меньше, чем строить тетраэдрическую сетку 
заново, но на скорость расчета задачи вид сетки кардинально не влияет.  

7. Решающее устройство  

Выбор решающего устройства и его параметров очень важен, так как в основном от него 
зависит достоверность вычислений. Неправильная настройка может привести к грубым 
ошибкам решения, которые очень трудно выявить. Так же очень важно правильно 
оптимизировать решение, так как, к примеру, даже не очень сложная трехмерная модель 
элемента кассетной конструкции рассчитывается десятки минут на компьютере с 
процессором Athlon 64 3000+ и 1 Gb оперативной памяти, а некоторые нелинейные 
нестационарные модели могут рассчитываться многие часы даже на очень мощном 
компьютере.  

Кнопка Solve или пункт меню Solve > Solve problem запускает решающее устройство с 
текущими настройками. Кнопка Restart или пункт меню Solve > Restart перезапускает 
решающее устройство используя текущие значения (поле температур или скоростей) как 
начальные. Если мы рассматриваем стационарную задачу, то нажатие этой кнопки не 
должно менять решение. Колебания значений в этом случае говорят о нестабильности 
решения. Эту команду целесообразно применять для сложных расчетов, когда можно 
получить приближенный вариант решения на грубой сетке и для линейного или 
стационарного решателя, а потом сделав более мелкую сетку и при необходимости 
изменив решатель на нелинейный или переходный пересчитать задачу. Зачастую это 
позволяет получить решение быстрее, чем сразу производя сложный расчет.  



Для изменения параметров нажмем F 11 Solve > Solver parameters … или 
соответствующую кнопку. Откроется окно:  

  

Если стоит галочка 
Auto select solver , значит программа в зависимости от прикладного режима подобрала 
наиболее подходящее устройство, для несложных вычислений чаще всего менять его не 
надо.  

Выбирая решающее устройство, надо в первую очередь определиться стационарный или 
переходный процесс мы изучаем. Если процесс нестационарный, то в подавляющем 
большинстве случаев подходит решатель Time Dependent . Для очень редких задач, 
связанных с нахождением собственных чисел дифференциальных уравнений, например 
волнового уравнения теплопроводности, надо выбирать решатель Eigenvalue .  

Если проблема стационарна, то надо определить линейна она или нелинейна. Если есть 
сомнения в линейности системы, то рекомендуется сразу устанавливать нелинейный 
решатель: если для линейной модели установить нелинейный решатель, то ответ будет 
корректен, но на вычисления затратится больше времени; а если для нелинейной задачи 
установить линейный решатель, то наверняка будут грубые ошибки.  

=> Внимание. Если в заданных коэффициентах присутствуют переменные 
(например, теплоемкость или теплопроводность) для которых мы задали 
зависимость от температуры или от других переменных, то задача нелинейная. Все 
задачи в которых учитывается теплообмен излучением, то есть где С или Ctrans 
(константа Стефана-Больцмана) не равна нулю – нелинейные. Модели, которые 
задают в прикладном режиме Incompressible Navier-Stokes практически всегда 
нелинейные.  

Для линейных и нелинейных стационарных задач можно выбрать параметрический 
решатель, в котором надо указать параметры, для которых задаётся несколько значений. 



Например, задать ряд разных теплопроводностей или мощностей для какого-либо объекта, 
а потом сравнить распределение температур при всех значениях параметра.  

После выбора решателя в поле Solver , задаем основные свойства.  

Для Time Dependent на вкладке General это Time stepping [шаги по времени] в поле 
Times в формате 0:10: 60 задаются временные слои. Здесь, от 0 до 60 секунд с 
промежутком 10 секунд. Единица измерения времени секунда, она устанавливается в 
Physics > Subdomain Settings в поле Time scaling coefficient . Если вместо 1 задать 1/60 , 
то единица измерения времени будет равна 1 минуте. Поля tolerance определяют ошибку 
на каждом шаге итерации. Галочка Allow complex number позволяет применять в 
расчетах комплексные числа это нужно в случаях, если мы задали коэффициенты PDE в 
комплексном виде. Вкладка Time Stepping определяет шаги по времени . Пункт Times to 
store in output определяет какие временные шаги будут выводится для постобработки 
вычислений. По умолчанию стоит Specified Times , то есть времена определённые на 
вкладке General . Для того чтобы получить значения всех шагов решающего устройства 
надо выбрать Time steps from solver . Вообще, решающее устройство выбирает шаги 
произвольно, в зависимости от динамики системы, то есть игнорирует заданные значения 
Times на вкладке General . Чтобы решающее устройство учитывало этот список 
(например, если внешние воздействия импульсные и решатель может «проскочить мимо 
них») надо установить Time steps taken by solver в значение Strict или Intermediate 
вместо стоящего по умолчанию Free . Если надо принудительно задать равномерный шаг 
по времени, то это делается в поле Manual Tuning of step size .  

Для Eigenvalue необходимо задать количество собственных чисел уравнения в поле 
Desired number of eigenvalues и около каких значений искать собственные числа в поле 
Search for eigenvalues around .  

Для параметрических решателей надо установить имя параметра, который будет 
изменяться в поле Name of parameter и значения которые он будет принимать в поле List 
of parameter values. Значения можно перечислить через пробел, задать в виде 0:10: 100 
или задать как функцию linspace(1,100,25) , то есть двадцать пять значений равномерно 
расположенных от 1 до 100.  

Для нелинейных решателей появляется вкладка Nonlinear где можно указать количество 
итераций, (по умолчанию стоит 25 ). Для сильно нелинейных проблем рекомендуется 
поставить галочку Highly nonlinear problem и увеличить количество итераций.  

Для всех режимов кроме Time Dependent можно установить галочку Adaptive Mesh 
Refinement , тогда в процессе решения сетка будет уточнена по сложному алгоритму. 
Если физика и геометрия достаточно сложна, и не очень ясно как задавать параметры 
сетки, рекомендуется установить эту галочку. Но это увеличит время вычисления.  

Кроме того, можно установить Matrix symmetry в значение Symmetric если наша 
матрица симметрична. Чаще всего это бывает, если мы рассматриваем процессы чистой 
кондукции или диффузии. При выборе соответствующего линейного решателя это 
ускорит расчет. Матрицы заведомо несимметричны в мультифизических моделях, 
моделях связанных с конвекцией или уравнением Навье-Стокса.  

Большая часть времени расчета занята решением систем линейных уравнений, отвечает за 
их решение Linear system solver . По умолчанию стоит Direсt ( UMFPACK ) этот 
решатель отнимает много ресурсов компьютера и для моделей требующих длительного 



расчета можно подобрать более подходящий. Если предыдущий решатель не работает, 
можно попробовать Direct (SPOOLES ) он требует меньше памяти, но работает 
нестабильно. В крайнем случае выбирается итеративный решатель GMRES . Для 
положительно определенных систем с симметричными матрицами  

[Способ определения положительно определенных систем с симметричными матрицами 
[symmetric, positive-definite systems] и методы настройки итеративных решателей 
подробно описаны в справке программы] в выбирается Direct Cholesky (TAUCS) или 
итеративный Conjugate Gradients . Итеративные решатели потребляют меньше памяти, 
но надо следить за тем, что они сходятся и в случае необходимости увеличивать 
количество итераций.  

Уравнения чистой кондукции и чистой диффузии в стандартных режимах являются в 
стационарном состоянии эллиптическими, а в нестационарном параболическими. Для них 
очень эффективно использовать решатель Geometric multigrid .  

После задания свойств нажимаем кнопку Solve или команду Solve > Solve Problem . Часто 
после получения решения, модель и её параметры (физические свойства и граничные 
условия) немного изменяются. И если эти изменения не очень велики, то можно 
использовать команду Solve > Update model , тогда задача пересчитываться не будет, а 
новые значения будут получены методом интерполяции. Так же можно нажать кнопку 
Restart , тогда задача пересчитается, но за начальные Init значения будут заданы те, 
которые были получены на прошлом этапе. Это может немного ускорить вычисления. Так 
же с помощью этой команды можно выявить нестабильность решения: если нажимая эту 
кнопку без изменения параметров модели мы получаем разные решения (осцилляции 
численного решения), то это говорит о нестабильности. В этом случае нужно уменьшить 
сетку или, если эта задача связана с конвекцией, применить Диффузионную стабилизацию 
в настройках физических свойств модели.  

7.Визуализация результатов 

После завершения решения автоматически включается режим Postprocessing mode 
[Режим постобработки] в котором можно наблюдать результаты вычисления. Вручную 

этот режим можно включить соответствующей кнопкой или командой Postprocessing 
> Postprocessing mode По умолчанию, в расчетах теплопереноса выводится поле 
температур, в расчетах диффузии - поле концентраций, а в расчетах по уравнению Навье-
Стокса - поле скоростей.  

Рассмотрим одномерный, стационарный режим: после расчета чаще всего требуется 
получить распределение какого либо параметра по оси. Например, распределение 
температуры по длине стенки. По умолчанию, оно выводится прямо в рабочей области в 
виде графика. В случае нестационарного режима, выводится график распределения для 
последнего временного слоя. Настройки визуализации включаются командой 
Postprocessing > Plot parameters … или F 12. Откроется окно Plot parameters с четырьмя 
вкладками (в режиме 1 D ).  

На вкладке General в поле Plot type надо выбрать какие параметры результатов 
вычисления будут отображаться, Line [Линия], Max / min marker [Метка максимума и 
минимума] и Geometry edges [Грани геометрии] – показывает или скрывает границы 
стенок. В поле Solution to use [Использование решения] в режиме переходного анализа 
можно выбрать временной слой (по умолчанию, изображается последний) в 



раскрывающемся списке Solution at time [решение для времени] . Если там выбрать пункт 
Interpolated , то в поле Time можно указать промежуточное значение времени и получить 
интерполированный расчет.  

  

 

Распределение температуры в трехслойной стенке  

   

В режиме параметрического решателя, в списке будут не временные слои, а значения 
параметра.  

На вкладке Line расположена галочка Line plot дублирующая аналогичную кнопку на 
вкладке General , поле Height data – данные по вертикальной оси – позволяет задать 
нужную нам переменную, которая будет отображаться по оси y . В режиме Heat transfer в 
поле Predefined quantities [Предопределенные значения] по умолчанию стоит температура, 
но есть возможность задать практически любой возможный параметр: Heat flux [Тепловой 
поток], Temperature gradient [Градиент температуры], а также все коэффициенты PDE 
(теплоемкость, теплопроводность и тп в случае теплопереноса) и все параметры 
граничных условий (например, внешнюю температуру или коэффициент теплоотдачи). 
При этом в поле Expression [Выражение] будет отображаться текущая переменная или 
задающее её выражение. К примеру, градиент температуры в программе задается так: 
gradT _ ht . В это поле можно заносить и свои произвольные выражения, таким образом, 
вместо распределения абсолютных значений температуры по толщине исследуемой 
стенки - можно получить график перегревов.  

В поле Line color можно выбрать Uniform [Одноцветный] график или, для наглядности, 
Line color expression задать зависимость цвета линии от любого параметра.  



На вкладке Max / Min можно задать параметры этих маркеров. На вкладке Animation в 
режиме переходного ( time dependent ) или параметрического ( parametric ) задаются 
параметры анимации результата вычислений. Анимацию можно сохранить в одном из 
нескольких видео форматов.  

В двумерном исследовании режим постобработки более обширен. На левой панели 
расположены кнопки предустановленных режимов. 2 D Surface Plot – выводит значение 
скалярного поля (температуры, скорости или концентрации) в цветовом виде. 3 D Surface 
Plot – выводит значение скалярного поля в виде трехмерной поверхности. Contour plot – 
выводит решение в виде изолиний (в режиме теплопереноса - изотермы). Arrow plot – 
выводит векторное поле (потока тепла, скоростей или потока диффузии) в виде стрелочек. 
Streamline plot – выводит векторное поле в виде линий потока. Line Plot – визуализация 
значений на границах в цветовом виде. Animate – в переходном режиме создает анимацию 
решения. Все эти кнопки дублируются в окне Postprocessing > Plot Parameters … F 12, где 
можно задать всевозможные параметры вывода результатов. На вкладке General можно 
отметить галочками все виды визуализации которые будут выводиться, а на вкладках 
задать их свойства. На каждой вкладке можно выбирать любые переменные или задавать 
свои, определять цветовое соответствие результатам, задавать диапазон выводимых 
параметров и многое другое.  

Чтобы получить значение отображаемой величины в конкретной точке – можно щелкнуть 
мышкой в необходимом месте фигуры. Значение будет выведено в строке сообщений под 
рабочей областью вместе с координатами точки. При горящем переключателе SNAP 
можно посмотреть только значения в узлах решетки. Если нажать кнопку Draw Point for 
Cross-Section Point Plot. А потом поставить её на фигуру, то откроется окно с графиком 
изменения температуры во времени. Кнопка Draw Line for Cross - Section Line Plot 
позволяет провести через фигуру прямую линию и получить график температуры вдоль 
этой линии. Эти кнопки дублируют пункт меню Postprocessing>Cross-Section Plot 
Parameters… который открывает окно с тремя вкладками . На вкладке General можно 
выбрать временные слои или (при параметрическом решателе) значения параметров, для 
которых будет строится график. Вкладки Point позволяет задать координаты точек, для 
которых будет построен график и переменную, от которой он строится. Вкладка Line так 
же задает переменную и координаты линии, есть возможность задать количество 
равноотстоящих параллельных линий. В случае переходного анализа будет построен 
график для каждого выделенного временного слоя.  

Пункт меню Domain Plot parameters позволяет получить вид решения для каждой 
области отдельно или распределение переменной на границах и в углах фигуры.  

В трехмерном режиме основным видом визуализации является Slice Plot [График 
сечений], в этом режиме показывается определенное количество сечений расчетной 
области с распределением заданной переменной. Isosurface Plot показывает 
изоповерхности. Subdomain Plot показывает распределение скалярного поля переменной 
по всему объему. Boundary Plot – показывает распределение температур на всех границах 
фигуры. Остальные режимы аналогичны 2 D . Все параметры соответствующих режимов 
визуализации настраиваются в окне Postprocessing > Plot Parameters … F 12  

Кроме того в трехмерном режиме можно видеть кнопки отвечающие за «освещение» и 
ракурс объекта.  

Часто возникает необходимость проинтегрировать какой либо параметр по объему, 
поверхности или ребру. Команды Postprocessing > Subdomain / Boundary / Edge 



Parameters … позволяют это сделать: можно выбрать необходимый элемент, задать 
переменную или выражение. Кстати, чтобы узнать площадь или объем (например, чтобы 
вычислить объемную мощность) объекта надо вместо подынтегрального выражения 
задать 1.  

Каждый из полученных графиков можно сохранить как в виде рисунка, так и в текстовый 
файл. Полностью экспортировать все полученные данные можно с помощью пункта меню 
File > Export > Postprocessing Data .  

 


